RubyGems Navigation menu

rubocop 0.57.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.23.0 - November 15, 2021 (511 ko)
  2. 1.22.3 - October 27, 2021 (508 ko)
  3. 1.22.2 - October 22, 2021 (508 ko)
  4. 1.22.1 - October 04, 2021 (507 ko)
  5. 1.22.0 - September 29, 2021 (506 ko)
  6. 0.57.1 - June 06, 2018 (391 ko)
Voir toutes les versions (194)

Dépendances de Runtime (7):

  • jaro_winkler ~> 1.5.1
  • parallel ~> 1.10
  • parser >= 2.5
  • powerpack ~> 0.1
  • rainbow < 4.0, >= 2.2.2
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Dépendances de Development (2):

  • bundler ~> 1.3
  • rack < 2.0, >= 1.6.9
  • Propriétaires:

    Auteurs:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    Total de contrôle SHA 256:

    ad25fe52d9be12bb0662dd32e84cc72067f2ab516a14bb5d557dfec15a74a2e6

    Total de téléchargements 193 747 124

    Pour cette version 238 824

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 2.1.0

    Requires MFA accounts: 1.23.0

    Liens: