RubyGems Navigation menu

rubocop 0.57.2

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.60.2 - January 24, 2024 (616 KB)
  2. 1.60.1 - January 17, 2024 (615 KB)
  3. 1.60.0 - January 15, 2024 (615 KB)
  4. 1.59.0 - December 11, 2023 (613 KB)
  5. 1.58.0 - December 01, 2023 (612 KB)
  6. 0.57.2 - June 12, 2018 (391 KB)
Show all versions (262 total)

Runtime Dependencies (7):

jaro_winkler ~> 1.5.1
parallel ~> 1.10
parser >= 2.5
powerpack ~> 0.1
rainbow < 4.0, >= 2.2.2
unicode-display_width >= 1.0.1, ~> 1.0

Development Dependencies (2):

bundler ~> 1.3
rack < 2.0, >= 1.6.9

Owners:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

468ca03be186a4c39f75535ad445bb073408cf2c75035105ac6b91dc04d9cbac

Total downloads 397,193,781

For this version 2,313,855

License:

MIT

Required Ruby Version: >= 2.1.0

New versions require MFA: true

Links: