RubyGems Navigation menu

rubocop 0.57.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 0.86.0 - June 22, 2020 (386 KB)
  2. 0.85.1 - June 07, 2020 (382 KB)
  3. 0.85.0 - June 01, 2020 (381 KB)
  4. 0.84.0 - May 21, 2020 (377 KB)
  5. 0.83.0 - May 11, 2020 (405 KB)
  6. 0.57.1 - June 06, 2018 (391 KB)
Show all versions (141 total)

Runtime Dependencies (7):

  • jaro_winkler ~> 1.5.1
  • parallel ~> 1.10
  • parser >= 2.5
  • powerpack ~> 0.1
  • rainbow < 4.0, >= 2.2.2
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (2):

  • bundler ~> 1.3
  • rack < 2.0, >= 1.6.9
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    ad25fe52d9be12bb0662dd32e84cc72067f2ab516a14bb5d557dfec15a74a2e6

    Total downloads 103,770,014

    For this version 221,291

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.1.0

    Links: