RubyGems Navigation menu

rubocop 1.45.1

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.63.5 - May 09, 2024 (623 KB)
  2. 1.63.4 - April 28, 2024 (623 KB)
  3. 1.63.3 - April 22, 2024 (623 KB)
  4. 1.63.2 - April 16, 2024 (623 KB)
  5. 1.63.1 - April 10, 2024 (623 KB)
  6. 1.45.1 - February 08, 2023 (580 KB)
Show all versions (271 total)

Runtime Dependencies (9):

json ~> 2.3
parallel ~> 1.10
parser >= 3.2.0.0
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 3.2.5, < 4.0
rubocop-ast >= 1.24.1, < 2.0
unicode-display_width >= 2.4.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

f5863c6aa3954e62d583f13a51d100bc45040454adca92b5e85ab0e247f251cb

Total downloads 420,290,336

For this version 1,761,721

License:

MIT

Required Ruby Version: >= 2.6.0

New versions require MFA: true

Version published with MFA: true

Links: