RubyGems Navigation menu

rubocop 1.40.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= 复制到剪贴板 已复制!

安装:
=

版本列表:

  1. 1.63.5 - May 09, 2024 (623.0 KB)
  2. 1.63.4 - April 28, 2024 (623.0 KB)
  3. 1.63.3 - April 22, 2024 (622.5 KB)
  4. 1.63.2 - April 16, 2024 (622.5 KB)
  5. 1.63.1 - April 10, 2024 (622.5 KB)
  6. 1.40.0 - December 08, 2022 (567.0 KB)
显示所有版本 (共 271 个)

Runtime 依赖 (9):

json ~> 2.3
parallel ~> 1.10
parser >= 3.1.2.1
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 3.2.5, < 4.0
rubocop-ast >= 1.23.0, < 2.0
unicode-display_width >= 1.4.0, < 3.0

Development 依赖 (1):

bundler >= 1.15.0, < 3.0

业主:

推送:

作者:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 校验和:

031881f824594fdb08713d5187c7bf07a11ff83fda869a7dd2d7765f92846a35

下载总量 420,696,448

这个版本 1,288,011

许可:

MIT

需要的 Ruby 版本: >= 2.6.0

新的版本需要开启多因素验证: true

使用多因素验证发布的版本: true

链接: