RubyGems Navigation menu

rubocop 1.35.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.58.0 - December 01, 2023 (612 KB)
  2. 1.57.2 - October 26, 2023 (608 KB)
  3. 1.57.1 - October 13, 2023 (608 KB)
  4. 1.57.0 - October 11, 2023 (607 KB)
  5. 1.56.4 - September 28, 2023 (606 KB)
  6. 1.35.0 - August 12, 2022 (553 KB)
Show all versions (258 total)

Runtime Dependencies (9):

json ~> 2.3
parallel ~> 1.10
parser >= 3.1.2.1
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 3.2.5, < 4.0
rubocop-ast >= 1.20.1, < 2.0
unicode-display_width >= 1.4.0, < 3.0

Development Dependencies (1):

bundler >= 1.15.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

7fdcffa6eff2272e0e31993743caec05d1d48e9e6de8d0f6c1a57b4e849183f1

Total downloads 374,764,838

For this version 792,551

License:

MIT

Required Ruby Version: >= 2.6.0

New versions require MFA: true

Version published with MFA: true

Links: