RubyGems Navigation menu

standard-rubocop-lts 1.0.10

Extended Standard Ruby Configs for Finely Aged Rubies; Compatible with rubocop-lts

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.10 - March 23, 2024 (22.5 KB)
  2. 1.0.9 - September 20, 2023 (20.5 KB)
  3. 1.0.8 - July 07, 2023 (20 KB)
  4. 1.0.7 - June 08, 2023 (20 KB)
  5. 1.0.6 - June 03, 2023 (19.5 KB)
Show all versions (11 total)

Runtime Dependencies (5):

rspec-block_is_expected ~> 1.0, >= 1.0.5
standard >= 1.35.1, < 2
standard-custom >= 1.0.2, < 2
standard-performance >= 1.3.1, < 2
version_gem >= 1.1.4, < 3

Development Dependencies (15):

kettle-soup-cover ~> 1.0, >= 1.0.2
kramdown ~> 2.4
rake ~> 13.0
rspec ~> 3.13
rspec-stubbed_env ~> 1.0, >= 1.0.1
rubocop-gradual ~> 0.3, >= 0.3.4
rubocop-md ~> 1.2, >= 1.2.2
rubocop-packaging ~> 0.5, >= 0.5.2
rubocop-rake ~> 0.6
rubocop-rspec ~> 2.27, >= 2.27.1
rubocop-shopify ~> 2.15, >= 2.15.1
rubocop-thread_safety ~> 0.5, >= 0.5.1
yard ~> 0.9, >= 0.9.36
yard-junk ~> 0.0

Owners:

Pushed by:

Authors:

  • Peter Boling

SHA 256 checksum:

bdce3407fb6683a305f7f2e186858033dc88013d95bdc6ec4de8df0be55a0e47

Signature validity period:

September 20, 2023 - September 19, 2024

Total downloads 8,388

For this version 1,158

License:

MIT

Required Ruby Version: >= 2.7.0

New versions require MFA: true

Version published with MFA: true

Links: