RubyGems Navigation menu

rubocop 1.5.2

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.60.2 - January 24, 2024 (616 KB)
  2. 1.60.1 - January 17, 2024 (615 KB)
  3. 1.60.0 - January 15, 2024 (615 KB)
  4. 1.59.0 - December 11, 2023 (613 KB)
  5. 1.58.0 - December 01, 2023 (612 KB)
  6. 1.5.2 - December 04, 2020 (448 KB)
Show all versions (262 total)

Runtime Dependencies (8):

parallel ~> 1.10
parser >= 2.7.1.5
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 0
rubocop-ast >= 1.2.0, < 2.0
unicode-display_width >= 1.4.0, < 2.0

Development Dependencies (1):

bundler >= 1.15.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

e552e6c2a0765a5faea5b0def4c13a6004bcdd2e947eb5693ee3900c5535444c

Total downloads 396,171,211

For this version 683,232

License:

MIT

Required Ruby Version: >= 2.4.0

New versions require MFA: true

Links: