RubyGems Navigation menu

rubocop 1.29.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.31.1 - June 29, 2022 (541 KB)
  2. 1.31.0 - June 27, 2022 (541 KB)
  3. 1.30.1 - June 06, 2022 (532 KB)
  4. 1.30.0 - May 26, 2022 (531 KB)
  5. 1.29.1 - May 12, 2022 (528 KB)
  6. 1.29.0 - May 06, 2022 (528 KB)
Show all versions (210 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.1.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 3.2.5, < 4.0
  • rubocop-ast >= 1.17.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    eb47f76dbc87b5b6eb449ace51a6f2819df2f1ee49734a866554ef80b8f478cc

    Total downloads 238,980,839

    For this version 332,971

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.6.0

    New versions require MFA: true

    Version published with MFA: true

    Links: