RubyGems Navigation menu

rubocop 1.28.1

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.56.3 - September 11, 2023 (605 KB)
  2. 1.56.2 - August 29, 2023 (604 KB)
  3. 1.56.1 - August 21, 2023 (604 KB)
  4. 1.56.0 - August 09, 2023 (604 KB)
  5. 1.55.1 - July 31, 2023 (603 KB)
  6. 1.28.1 - April 21, 2022 (525 KB)
Show all versions (253 total)

Runtime Dependencies (8):

parallel ~> 1.10
parser >= 3.1.0.0
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 0
rubocop-ast >= 1.17.0, < 2.0
unicode-display_width >= 1.4.0, < 3.0

Development Dependencies (1):

bundler >= 1.15.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

d608991e7f0038b0bd3012ba5c6e59aba587dc0451a36ee3f970330c380b59c4

Total downloads 356,040,781

For this version 351,057

License:

MIT

Required Ruby Version: >= 2.5.0

New versions require MFA: true

Version published with MFA: true

Links: