RubyGems Navigation menu

rubocop 1.22.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.23.0 - November 15, 2021 (511 KB)
  2. 1.22.3 - October 27, 2021 (508 KB)
  3. 1.22.2 - October 22, 2021 (508 KB)
  4. 1.22.1 - October 04, 2021 (507 KB)
  5. 1.22.0 - September 29, 2021 (506 KB)
Show all versions (194 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.12.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    2784830587b80e019661015ee5c9e030248985dabc590ddd84d7aca0ddc26a81

    Total downloads 193,855,335

    For this version 229,774

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Requires MFA accounts: Since 1.23.0

    Links: