RubyGems Navigation menu

rubocop 1.20.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.22.2 - October 22, 2021 (508 KB)
  2. 1.22.1 - October 04, 2021 (507 KB)
  3. 1.22.0 - September 29, 2021 (506 KB)
  4. 1.21.0 - September 13, 2021 (498 KB)
  5. 1.20.0 - August 26, 2021 (496 KB)
Show all versions (192 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.9.1, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    46f6c5d45a25f2c75cf8c92149e91e8680dac7f6056ebb92d979f36ff890d17f

    Total downloads 187,037,585

    For this version 985,467

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Links: