RubyGems Navigation menu

rubocop 1.12.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.14.0 - May 05, 2021 (478 KB)
  2. 1.13.0 - April 20, 2021 (477 KB)
  3. 1.12.1 - April 04, 2021 (477 KB)
  4. 1.12.0 - March 24, 2021 (476 KB)
  5. 1.11.0 - March 01, 2021 (473 KB)
Show all versions (176 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 3.0.0.0
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.8, < 3.0
  • rexml >= 0
  • rubocop-ast >= 1.2.0, < 2.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 3.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    dc9150badc782e37fbf572357b132ad3db2a11485635595b269d7bae0c047ec4

    Total downloads 156,581,167

    For this version 539,540

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.4.0

    Links: