RubyGems Navigation menu

rubocop 0.85.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.1.0 - October 29, 2020 (432 KB)
  2. 1.0.0 - October 21, 2020 (424 KB)
  3. 0.93.1 - October 12, 2020 (422 KB)
  4. 0.93.0 - October 08, 2020 (421 KB)
  5. 0.92.0 - September 25, 2020 (420 KB)
  6. 0.85.0 - June 01, 2020 (381 KB)
Show all versions (154 total)

Runtime Dependencies (8):

  • parallel ~> 1.10
  • parser >= 2.7.0.1
  • rainbow >= 2.2.2, < 4.0
  • regexp_parser >= 1.7
  • rexml >= 0
  • rubocop-ast >= 0.0.3
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 2.0
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    3963352c8187a06dbf3f65358ab91eff3502792da8dbb0e8329eeb7fb74715bc

    Total downloads 123,294,488

    For this version 296,005

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.4.0

    Links: