RubyGems Navigation menu

rubocop 0.65.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.60.2 - January 24, 2024 (616 KB)
  2. 1.60.1 - January 17, 2024 (615 KB)
  3. 1.60.0 - January 15, 2024 (615 KB)
  4. 1.59.0 - December 11, 2023 (613 KB)
  5. 1.58.0 - December 01, 2023 (612 KB)
  6. 0.65.0 - February 19, 2019 (413 KB)
Show all versions (262 total)

Runtime Dependencies (8):

jaro_winkler ~> 1.5.1
parallel ~> 1.10
parser >= 2.5, != 2.5.1.1
powerpack ~> 0.1
psych >= 3.1.0
rainbow >= 2.2.2, < 4.0

Development Dependencies (2):

bundler >= 1.3.0, < 3.0
rack >= 2.0

Owners:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

c6ffcb57bab1cecbcd0240948c2bba65f422abc1e72bef461fb4f31cd9bbd19a

Total downloads 396,102,765

For this version 2,596,070

License:

MIT

Required Ruby Version: >= 2.2.2

New versions require MFA: true

Links: