RubyGems Navigation menu

rubocop 0.49.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versiones:

  1. 1.36.0 - September 01, 2022 (555 KB)
  2. 1.35.1 - August 22, 2022 (553 KB)
  3. 1.35.0 - August 12, 2022 (553 KB)
  4. 1.34.1 - August 09, 2022 (548 KB)
  5. 1.34.0 - August 09, 2022 (548 KB)
  6. 0.49.1 - May 29, 2017 (314 KB)
Mostrar todas las versiones (218 total)

dependencias de Runtime (6):

  • parallel ~> 1.10
  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • dependencias de Development (1):

  • bundler ~> 1.3
  • Propietarios:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    bcb37220633a570611b68bf8d4649414624d90fad83a7bf8310940f61df51ed7

    Total de descargas 262.047.808

    Para esta versión 10.376.399

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    MIT

    Versión de Ruby requerida: >= 2.0.0

    New versions require MFA: true

    Enlace: