RubyGems Navigation menu

rubocop 0.49.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.1.0 - October 29, 2020 (432 KB)
  2. 1.0.0 - October 21, 2020 (424 KB)
  3. 0.93.1 - October 12, 2020 (422 KB)
  4. 0.93.0 - October 08, 2020 (421 KB)
  5. 0.92.0 - September 25, 2020 (420 KB)
  6. 0.49.1 - May 29, 2017 (314 KB)
Show all versions (154 total)

Runtime Dependencies (6):

  • parallel ~> 1.10
  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (1):

  • bundler ~> 1.3
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    bcb37220633a570611b68bf8d4649414624d90fad83a7bf8310940f61df51ed7

    Total downloads 123,268,764

    For this version 8,382,672

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.0.0

    Links: