RubyGems Navigation menu

rubocop 0.49.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.8.1 - January 11, 2021 (459 ko)
  2. 1.8.0 - January 07, 2021 (459 ko)
  3. 1.7.0 - December 25, 2020 (456 ko)
  4. 1.6.1 - December 10, 2020 (451 ko)
  5. 1.6.0 - December 09, 2020 (451 ko)
  6. 0.49.0 - May 24, 2017 (312 ko)
Voir toutes les versions (168)

Dépendances de Runtime (6):

  • parallel ~> 1.10
  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Dépendances de Development (1):

  • bundler ~> 1.3
  • Propriétaires:

    Auteurs:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    Total de contrôle SHA 256:

    3af20292590127c5e5a67a08e84642bb9d1f555cb8ed16717980c8b524ed038f

    Total de téléchargements 137 892 878

    Pour cette version 283 045

    Gemfile:
    = Copier Copié!

    installation:
    =

    License:

    MIT

    Version de Ruby requise: >= 2.0.0

    Liens: