RubyGems Navigation menu

rubocop 0.74.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 0.89.1 - August 10, 2020 (408 KB)
  2. 0.89.0 - August 05, 2020 (408 KB)
  3. 0.88.0 - July 13, 2020 (396 KB)
  4. 0.87.1 - July 07, 2020 (392 KB)
  5. 0.87.0 - July 06, 2020 (391 KB)
  6. 0.74.0 - July 31, 2019 (382 KB)
Show all versions (146 total)

Runtime Dependencies (6):

  • jaro_winkler ~> 1.5.1
  • parallel ~> 1.10
  • parser >= 2.6
  • rainbow >= 2.2.2, < 4.0
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.4.0, < 1.7
  • Development Dependencies (1):

  • bundler >= 1.15.0, < 3.0
  • Owners:

    Pushed by:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    d3abbf59133f5fce2bea961bb363a3c2f7d2e36ffc30fd11de5c2c9cb456fe72

    Total downloads 109,932,289

    For this version 4,720,290

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.3.0

    Links: