RubyGems Navigation menu

rubocop 0.56.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versões:

  1. 0.92.0 - September 25, 2020 (420 KB)
  2. 0.91.1 - September 23, 2020 (419 KB)
  3. 0.91.0 - September 15, 2020 (419 KB)
  4. 0.90.0 - September 01, 2020 (415 KB)
  5. 0.89.1 - August 10, 2020 (408 KB)
  6. 0.56.0 - May 14, 2018 (387 KB)
Mostrar todas as versões (150)

Runtime Dependencies (6):

  • parallel ~> 1.10
  • parser >= 2.5
  • powerpack ~> 0.1
  • rainbow < 4.0, >= 2.2.2
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (2):

  • bundler ~> 1.3
  • rack < 2.0, >= 1.6.9
  • Donos:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    687f9418a1475911fdd0cf7c57009620daef2caffe5692b621dc6d1abfb04212

    Total de downloads 118.313.856

    Desta versão 1.205.423

    Gemfile:
    = Copy to clipboard Copied!

    instalar:
    =

    Licença:

    MIT

    Versão Requerida do Ruby: >= 2.1.0

    Links: