RubyGems Navigation menu

rubocop 0.48.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versiones:

  1. 1.23.0 - November 15, 2021 (500 KB)
  2. 1.22.3 - October 27, 2021 (500 KB)
  3. 1.22.2 - October 22, 2021 (500 KB)
  4. 1.22.1 - October 04, 2021 (500 KB)
  5. 1.22.0 - September 29, 2021 (500 KB)
  6. 0.48.1 - April 03, 2017 (300 KB)
Mostrar todas las versiones (194 total)

dependencias de Runtime (5):

  • parser < 3.0, >= 2.3.3.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • dependencias de Development (1):

  • bundler ~> 1.3
  • Propietarios:

    Autores:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    002f6b49013abdc05c68ae75433c48d3ee7f1baa70674d60bf1cc310e210fbd7

    Total de descargas 193.716.521

    Para esta versión 2.370.325

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencia:

    MIT

    Versión de Ruby requerida: >= 2.0.0

    Requires MFA accounts: 1.23.0

    Enlace: