RubyGems Navigation menu

rubocop 0.44.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 0.89.1 - August 10, 2020 (408 KB)
  2. 0.89.0 - August 05, 2020 (408 KB)
  3. 0.88.0 - July 13, 2020 (396 KB)
  4. 0.87.1 - July 07, 2020 (392 KB)
  5. 0.87.0 - July 06, 2020 (391 KB)
  6. 0.44.0 - October 13, 2016 (269 KB)
Show all versions (146 total)

Runtime Dependencies (5):

  • parser < 3.0, >= 2.3.1.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (1):

  • bundler ~> 1.3
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    b124c8255b6570964a53e9d17d3861970d71788f8caa7819335cfac291eb8093

    Total downloads 110,435,846

    For this version 4,065

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.0.0

    Links: