RubyGems Navigation menu

rubocop 0.41.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 0.88.0 - July 13, 2020 (396 KB)
  2. 0.87.1 - July 07, 2020 (392 KB)
  3. 0.87.0 - July 06, 2020 (391 KB)
  4. 0.86.0 - June 22, 2020 (386 KB)
  5. 0.85.1 - June 07, 2020 (382 KB)
  6. 0.41.0 - June 25, 2016 (253 KB)
Show all versions (144 total)

Runtime Dependencies (5):

  • parser < 3.0, >= 2.3.1.1
  • powerpack ~> 0.1
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.7
  • unicode-display_width >= 1.0.1, ~> 1.0
  • Development Dependencies (1):

  • bundler ~> 1.3
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    9580eb20ce098b7a0c06730f92e07ff71da25b803b5a28580ea571b17422e008

    Total downloads 105,270,153

    For this version 25,290

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: