RubyGems Navigation menu

rubocop 0.24.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.25.0 - January 18, 2022 (517 KB)
  2. 1.24.1 - December 31, 2021 (516 KB)
  3. 1.24.0 - December 23, 2021 (516 KB)
  4. 1.23.0 - November 15, 2021 (511 KB)
  5. 1.22.3 - October 27, 2021 (508 KB)
  6. 0.24.1 - July 03, 2014 (266 KB)
Show all versions (197 total)

Runtime Dependencies (5):

  • json < 2, >= 1.7.7
  • parser < 3.0, >= 2.2.0.pre.3
  • powerpack ~> 0.0.6
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.0
  • simplecov ~> 0.7
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    1c58201dcd9e9cb364a5865b71d29c1371379c3c6c6896d6aaef292d0468bc54

    Total downloads 202,961,442

    For this version 241,397

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.2

    Requires MFA accounts: Since 1.23.0

    Links: