RubyGems Navigation menu

rubocop 0.17.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.23.0 - November 15, 2021 (511 KB)
  2. 1.22.3 - October 27, 2021 (508 KB)
  3. 1.22.2 - October 22, 2021 (508 KB)
  4. 1.22.1 - October 04, 2021 (507 KB)
  5. 1.22.0 - September 29, 2021 (506 KB)
  6. 0.17.0 - January 23, 2014 (191 KB)
Show all versions (194 total)

Runtime Dependencies (4):

  • json ~> 1.8
  • parser ~> 2.1.3
  • powerpack ~> 0.0.6
  • rainbow ~> 1.99.1
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 2.14
  • simplecov ~> 0.7
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov

    SHA 256 checksum:

    529e1af94a20544424c6d7603ca62459acdfe10466503416a6eae5c0d3fb67e3

    Total downloads 193,775,086

    For this version 28,943

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.2

    Requires MFA accounts: Since 1.23.0

    Links: