RubyGems Navigation menu

gir_ffi 0.15.9

GirFFI creates bindings for GObject-based libraries at runtime based on introspection data provided by the GObject Introspection Repository (GIR) system. Bindings are created at runtime and use FFI to interface with the C libraries. In cases where the GIR does not provide enough or correct information to create sane bindings, overrides may be created.

Versions:

  1. 0.15.9 - December 05, 2021 (77 KB)
  2. 0.15.8 - November 20, 2021 (77 KB)
  3. 0.15.7 - January 15, 2021 (77.5 KB)
  4. 0.15.6 - January 10, 2021 (77.5 KB)
  5. 0.15.5 - November 13, 2020 (77 KB)
Show all versions (86 total)

Runtime Dependencies (2):

  • ffi ~> 1.8
  • ffi-bit_masks ~> 0.1.1
  • Development Dependencies (12):

    Owners:

    Pushed by:

    Authors:

    • Matijs van Zuijlen

    SHA 256 checksum:

    70e4712828285df7a6c114e04453efda99bf6b232cc637911ce0d263c10538f3

    Total downloads 236,090

    For this version 3,897

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    LGPL-2.1+

    Required Ruby Version: >= 2.6.0

    Requires MFA accounts: Since 0.15.8

    Links: