RubyGems Navigation menu

dry-types 1.5.1

Type system for Ruby supporting coercions, constraints and complex types like structs, value objects, enums etc

Gemfile:
= Copier Copié!

installation:
=

Versions:

  1. 1.7.2 - January 05, 2024 (45,5 ko)
  2. 1.7.1 - February 17, 2023 (45,5 ko)
  3. 1.7.0 - November 04, 2022 (45,5 ko)
  4. 1.6.1 - October 15, 2022 (44,5 ko)
  5. 1.6.0 - October 15, 2022 (44,5 ko)
  6. 1.5.1 - February 16, 2021 (44 ko)
Voir toutes les versions (47)

Dépendances de Runtime (5):

dry-container ~> 0.3
dry-core ~> 0.5, >= 0.5
dry-inflector ~> 0.1, >= 0.1.2
dry-logic ~> 1.0, >= 1.0.2

Dépendances de Development (5):

bundler >= 0
dry-monads ~> 1.0
rake >= 0
rspec >= 0
yard >= 0

Propriétaires:

Pushed by:

Auteurs:

  • Piotr Solnica

Total de contrôle SHA 256:

= Copier Copié!

Total de téléchargements 111 304 898

Pour cette version 28 594 497

License:

MIT

Version de Ruby requise: >= 2.5.0

Liens: