RubyGems Navigation menu

dry-types 1.5.0

Type system for Ruby supporting coercions, constraints and complex types like structs, value objects, enums etc

Versions:

  1. 1.7.0 - November 04, 2022 (45.5 KB)
  2. 1.6.1 - October 15, 2022 (44.5 KB)
  3. 1.6.0 - October 15, 2022 (44.5 KB)
  4. 1.5.1 - February 16, 2021 (44 KB)
  5. 1.5.0 - January 21, 2021 (44 KB)
Show all versions (45 total)

Runtime Dependencies (5):

dry-container ~> 0.3
dry-core ~> 0.5, >= 0.5
dry-inflector ~> 0.1, >= 0.1.2
dry-logic ~> 1.0, >= 1.0.2

Development Dependencies (5):

bundler >= 0
dry-monads ~> 1.0
rake >= 0
rspec >= 0
yard >= 0

Owners:

Pushed by:

Authors:

  • Piotr Solnica

SHA 256 checksum:

4a684301131df819714d8f0193936157f5476229d2ca471c4f89752b3a729542

Total downloads 70,022,539

For this version 740,551

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 2.5.0

Links: