RubyGems Navigation menu

cf-uaac 4.5.0

Client command line tools for interacting with the CloudFoundry User Account and Authorization (UAA) server. The UAA is an OAuth2 Authorization Server so it can be used by webapps and command line apps to obtain access tokens to act on behalf of users. The tokens can then be used to access protected resources in a Resource Server. This library can be used by clients (as a convenient wrapper for mainstream oauth gems) or by resource servers.

Versions:

  1. 4.5.0 - January 21, 2022 (135 KB)
  2. 4.4.0 - January 14, 2022 (135 KB)
  3. 4.3.0 - October 27, 2021 (135 KB)
  4. 4.2.0 - August 27, 2019 (135 KB)
  5. 4.1.0 - November 01, 2017 (135 KB)
Show all versions (38 total)

Runtime Dependencies (7):

  • cf-uaa-lib ~> 4.0
  • em-http-request ~> 1.1, >= 1.1.2
  • eventmachine ~> 1.0, >= 1.0.3
  • highline ~> 2.0
  • json_pure >= 1.8.1, < 3.0
  • launchy ~> 2.4, >= 2.4.2
  • rack >= 1.5.2, < 3.0
  • Development Dependencies (6):

  • ci_reporter >= 1.9.2, ~> 2.0
  • ci_reporter_rspec ~> 1.0
  • rake >= 10.3.1, ~> 13.0
  • rspec >= 2.14.1, ~> 3.9
  • simplecov ~> 0.21.2
  • simplecov-rcov ~> 0.2.3
  • Owners:

    Pushed by:

    Authors:

    • Dave Syer, Dale Olds, Joel D'sa, Vidya Valmikinathan, Luke Taylor

    SHA 256 checksum:

    5ed146252a3efba059902a2acae739ce659c4d16369300fcf9986d76414303df

    Total downloads 1,905,316

    For this version 185

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Apache-2.0

    Required Ruby Version: >= 0

    Links: