RubyGems Navigation menu

beaker 5.5.0

Puppet's accceptance testing harness

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 6.1.0 - June 04, 2024 (285 KB)
  2. 6.0.0 - May 28, 2024 (285 KB)
  3. 5.8.1 - May 06, 2024 (290 KB)
  4. 5.8.0 - March 22, 2024 (290 KB)
  5. 5.7.0 - February 13, 2024 (290 KB)
  6. 5.5.0 - October 02, 2023 (290 KB)
Show all versions (228 total)

Runtime Dependencies (14):

bcrypt_pbkdf >= 1.0, < 2.0
ed25519 >= 1.2, < 2.0
hocon ~> 1.0
inifile ~> 3.0
in-parallel >= 0.1, < 2.0
minitar ~> 0.6
minitest ~> 5.4
net-scp >= 1.2, < 5.0
net-ssh ~> 7.1
rexml ~> 3.2, >= 3.2.5
rsync ~> 1.0.9
thor >= 1.0.1, < 2.0

Development Dependencies (4):

fakefs ~> 2.4
rake ~> 13.0
rspec ~> 3.0

Owners:

Pushed by:

Authors:

  • Puppet

SHA 256 checksum:

baf0a043cc3534c47540cb6e049bca1f8f74977541d24e1bf7727a668a203276

Total downloads 4,378,643

For this version 13,850

License:

Apache-2.0

Required Ruby Version: >= 2.7

Links: