RubyGems Navigation menu

minitar 0.9

The minitar library is a pure-Ruby library that provides the ability to deal with POSIX tar(1) archive files. This is release 0.9, adding a minor feature to Minitar.unpack and Minitar::Input#extract_entry that when <tt>:fsync => false</tt> is provided, fsync will be skipped. minitar (previously called Archive::Tar::Minitar) is based heavily on code originally written by Mauricio Julio Fernández Pradier for the rpa-base project.

Versions:

  1. 0.9 - September 05, 2019 (32 KB)
  2. 0.8 - January 05, 2019 (32.5 KB)
  3. 0.7 - October 28, 2018 (30.5 KB)
  4. 0.6.1 - February 08, 2017 (28.5 KB)
  5. 0.6 - February 07, 2017 (28 KB)
Show all versions (7 total)

Development Dependencies (10):

  • hoe ~> 3.18
  • hoe-doofus ~> 1.0
  • hoe-gemspec2 ~> 1.1
  • hoe-git ~> 1.6
  • hoe-rubygems ~> 1.0
  • hoe-travis ~> 1.2
  • minitest ~> 5.11
  • minitest-autotest >= 1.0, < 2
  • rake >= 10.0, < 12
  • rdoc >= 0.0
  • Owners:

    Pushed by:

    Authors:

    • Austin Ziegler

    SHA 256 checksum:

    23c0bebead35dbfe9e24088dc436c8a233d03f51d365a686b9a11dd30dc2d588

    Total downloads 18,874,481

    For this version 2,413,778

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    Licenses:

    Ruby, BSD-2-Clause

    Required Ruby Version: >= 1.8

    Links: