RubyGems Navigation menu

truemail 2.6.1

Configurable framework agnostic plain Ruby email validator. Verify email via Regex, DNS, SMTP and even more.

Versions:

  1. 2.7.2 - May 02, 2022 (41 KB)
  2. 2.7.1 - March 02, 2022 (40.5 KB)
  3. 2.7.0 - February 23, 2022 (41 KB)
  4. 2.6.6 - February 09, 2022 (40.5 KB)
  5. 2.6.5 - February 09, 2022 (40.5 KB)
  6. 2.6.1 - January 04, 2022 (39.5 KB)
Show all versions (71 total)

Runtime Dependencies (1):

  • simpleidn ~> 0.2.1
  • Development Dependencies (16):

  • bundler-audit ~> 0.9.0.1
  • dns_mock ~> 1.4, >= 1.4.4
  • fasterer ~> 0.9.0
  • ffaker ~> 2.20
  • json_matchers ~> 0.11.1
  • overcommit ~> 0.58.0
  • pry-byebug ~> 3.9
  • rake ~> 13.0, >= 13.0.6
  • reek ~> 6.0, >= 6.0.6
  • rspec ~> 3.10
  • rubocop ~> 1.24
  • rubocop-performance ~> 1.13
  • rubocop-rspec ~> 2.7
  • simplecov ~> 0.17.1
  • truemail-rspec ~> 0.7.0
  • webmock ~> 3.14
  • Owners:

    Pushed by:

    Authors:

    • Vladislav Trotsenko

    SHA 256 checksum:

    e476bf4631ddf3daf72e3d84bff8689950871e1879d20719fc578227d2e7d86f

    Total downloads 377,196

    For this version 18,986

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Links: