RubyGems Navigation menu

truemail 2.5.0

Configurable framework agnostic plain Ruby email validator. Verify email via Regex, DNS, SMTP and even more.

Versions:

  1. 2.5.2 - October 06, 2021 (40 KB)
  2. 2.5.1 - October 01, 2021 (40 KB)
  3. 2.5.0 - September 01, 2021 (40 KB)
  4. 2.4.9 - August 20, 2021 (40 KB)
  5. 2.4.8 - August 12, 2021 (39.5 KB)
Show all versions (59 total)

Runtime Dependencies (1):

  • simpleidn ~> 0.2.1
  • Development Dependencies (17):

  • bundler ~> 2.2, >= 2.2.26
  • bundler-audit ~> 0.8.0
  • dns_mock ~> 1.4, >= 1.4.1
  • fasterer ~> 0.9.0
  • ffaker ~> 2.19
  • json_matchers ~> 0.11.1
  • overcommit ~> 0.58.0
  • pry-byebug ~> 3.9
  • rake ~> 13.0, >= 13.0.6
  • reek ~> 6.0, >= 6.0.6
  • rspec ~> 3.10
  • rubocop ~> 1.19, >= 1.19.1
  • rubocop-performance ~> 1.11, >= 1.11.5
  • rubocop-rspec ~> 2.4
  • simplecov ~> 0.17.1
  • truemail-rspec ~> 0.7.0
  • webmock ~> 3.14
  • Owners:

    Pushed by:

    Authors:

    • Vladislav Trotsenko

    SHA 256 checksum:

    b06a28da2c8d57103a8d04eb132860f69d67cbfe456154a2cada119ac4017d7f

    Total downloads 214,383

    For this version 8,730

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Links: