RubyGems Navigation menu

truemail 2.2.3

Configurable framework agnostic plain Ruby email validator. Verify email via Regex, DNS and SMTP.

Versions:

  1. 2.6.2 - January 19, 2022 (39.5 KB)
  2. 2.6.1 - January 04, 2022 (39.5 KB)
  3. 2.6.0 - December 28, 2021 (39 KB)
  4. 2.5.4 - December 03, 2021 (40 KB)
  5. 2.5.3 - November 08, 2021 (40 KB)
  6. 2.2.3 - January 12, 2021 (36.5 KB)
Show all versions (64 total)

Runtime Dependencies (1):

  • simpleidn ~> 0.1.1
  • Development Dependencies (15):

  • bundler ~> 1.16
  • bundler-audit ~> 0.7.0.1
  • faker ~> 2.15, >= 2.15.1
  • fasterer ~> 0.8.3
  • json_matchers ~> 0.11.1
  • overcommit ~> 0.57.0
  • pry-byebug ~> 3.9
  • rake ~> 13.0, >= 13.0.3
  • reek ~> 6.0, >= 6.0.3
  • rspec ~> 3.10
  • rubocop ~> 1.8, >= 1.8.1
  • rubocop-performance ~> 1.9, >= 1.9.2
  • rubocop-rspec ~> 2.1
  • simplecov ~> 0.17.1
  • truemail-rspec ~> 0.3.3
  • Owners:

    Pushed by:

    Authors:

    • Vladislav Trotsenko

    SHA 256 checksum:

    671ae37bfdd011c16c0ce68f9e21be1e0c58aa0d948cc438735b43f2947204b8

    Total downloads 272,118

    For this version 5,278

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.5.0

    Links: