RubyGems Navigation menu

sinatra-r18n 5.0.2

A Sinatra extension that provides i18n support to translate your web application. It is just a wrapper for R18n core library. It has nice Ruby-style syntax, filters, flexible locales, custom loaders, translation support for any classes, time and number localization, several user language support, agnostic core package with out-of-box support for Rails, Sinatra and desktop applications.

Versions:

  1. 5.0.2 - April 02, 2021 (14.5 KB)
  2. 5.0.1 - March 03, 2021 (14.5 KB)
  3. 4.0.0 - January 29, 2020 (10.5 KB)
  4. 3.2.0 - November 08, 2018 (10.5 KB)
  5. 3.1.2 - September 03, 2018 (10.5 KB)
Show all versions (64 total)

Runtime Dependencies (2):

  • r18n-core ~> 5.0
  • sinatra >= 1.3, < 3
  • Development Dependencies (10):

  • codecov ~> 0.5.0
  • gem_toys ~> 0.7.1
  • pry-byebug ~> 3.9
  • rack-test ~> 1.1
  • rspec ~> 3.10
  • rubocop ~> 1.6
  • rubocop-performance ~> 1.9
  • rubocop-rake ~> 0.5.1
  • simplecov ~> 0.21.0
  • toys ~> 0.11.0
  • Owners:

    Pushed by:

    Authors:

    • Andrey Sitnik, Alexander Popov

    SHA 256 checksum:

    0ac7d8894842cacfd9828ed8dcc0a07b153a8639020425d6d3698d3b5dd5f895

    Total downloads 239,864

    For this version 826

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    LGPL-3.0

    Required Ruby Version: >= 2.5, < 4

    Links: