RubyGems Navigation menu

shopify_api 9.4.1

The Shopify API gem allows Ruby developers to programmatically access the admin section of Shopify stores. The API is implemented as JSON or XML over HTTP using all four verbs (GET/POST/PUT/DELETE). Each resource, like Order, Product, or Collection, has its own URL and is manipulated in isolation.

Versions:

  1. 9.4.1 - March 30, 2021 (120 KB)
  2. 9.4.0 - February 24, 2021 (119 KB)
  3. 9.3.0 - January 27, 2021 (119 KB)
  4. 9.2.0 - July 14, 2020 (118 KB)
  5. 9.1.0 - April 15, 2020 (106 KB)
Show all versions (101 total)

Runtime Dependencies (3):

  • activeresource >= 4.1.0, < 6.0.0
  • graphql-client >= 0
  • rack >= 0
  • Development Dependencies (8):

    Owners:

    Pushed by:

    Authors:

    • Shopify

    SHA 256 checksum:

    b71b8cf07f02c0e4014d5e1288cd81a3c579cc213246001dc7a71ea563ce1d03

    Total downloads 3,498,727

    For this version 85,716

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.4

    Links: