RubyGems Navigation menu

ruby-xz 0.2.3

These are simple Ruby bindings for the liblzma library (http://tukaani.org/xz/), which is best known for the extreme compression ratio its native XZ format achieves. Since FFI is used to implement the bindings, no compilation is needed and they should work with JRuby as well.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.3 - March 28, 2022 (24.5 KB)
  2. 1.0.2 - November 29, 2021 (24.5 KB)
  3. 1.0.1 - November 13, 2021 (24.5 KB)
  4. 1.0.0 - May 20, 2018 (24 KB)
  5. 0.2.3 - December 29, 2015 (20 KB)
Show all versions (11 total)

Runtime Dependencies (2):

ffi ~> 1.9
io-like ~> 0.3

Development Dependencies (1):

Owners:

Authors:

  • Marvin Gülker

SHA 256 checksum:

bcd9914521eb56de369ff1510599ff51c42a473891e44e377c280130f7be6f85

Total downloads 6,048,415

For this version 5,877,535

License:

MIT

Required Ruby Version: >= 1.9.3

New versions require MFA: true

Links: