RubyGems Navigation menu

rubocop 0.26.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.22.2 - October 22, 2021 (508 KB)
  2. 1.22.1 - October 04, 2021 (507 KB)
  3. 1.22.0 - September 29, 2021 (506 KB)
  4. 1.21.0 - September 13, 2021 (498 KB)
  5. 1.20.0 - August 26, 2021 (496 KB)
  6. 0.26.0 - September 03, 2014 (288 KB)
Show all versions (192 total)

Runtime Dependencies (5):

  • astrolabe ~> 1.3
  • parser < 3.0, >= 2.2.0.pre.4
  • powerpack ~> 0.0.6
  • rainbow < 3.0, >= 1.99.1
  • ruby-progressbar ~> 1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 3.0
  • simplecov ~> 0.7
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

    SHA 256 checksum:

    773ed161beab33976b5760a2f5db27db3447726dd1389212c60668889f9e6091

    Total downloads 187,109,940

    For this version 102,720

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: