RubyGems Navigation menu

rubocop 0.14.1

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.64.0 - May 23, 2024 (626 KB)
  2. 1.63.5 - May 09, 2024 (623 KB)
  3. 1.63.4 - April 28, 2024 (623 KB)
  4. 1.63.3 - April 22, 2024 (623 KB)
  5. 1.63.2 - April 16, 2024 (623 KB)
  6. 0.14.1 - October 10, 2013 (155 KB)
Show all versions (272 total)

Runtime Dependencies (3):

parser ~> 2.0
powerpack ~> 0.0.6
rainbow >= 1.1.4

Development Dependencies (5):

bundler ~> 1.3
rake ~> 10.1
rspec ~> 2.14
simplecov ~> 0.7
yard ~> 0.8

Owners:

Authors:

  • Bozhidar Batsov

SHA 256 checksum:

6e164c3d0a55e543012eb814e11b25c431d32a04393b6f86ebbad6d21a493f2c

Total downloads 422,279,905

For this version 63,274

License:

MIT

Required Ruby Version: >= 1.9.2

New versions require MFA: true

Links: