RubyGems Navigation menu

rubocop 0.12.0

Automatic Ruby code style checking tool. Aims to enforce the community-driven Ruby Style Guide.

Versions:

  1. 1.36.0 - September 01, 2022 (555 KB)
  2. 1.35.1 - August 22, 2022 (553 KB)
  3. 1.35.0 - August 12, 2022 (553 KB)
  4. 1.34.1 - August 09, 2022 (548 KB)
  5. 1.34.0 - August 09, 2022 (548 KB)
  6. 0.12.0 - August 23, 2013 (128 KB)
Show all versions (218 total)

Runtime Dependencies (4):

  • backports ~> 3.3.3
  • parser ~> 2.0.0.pre6
  • powerpack ~> 0.0.3
  • rainbow >= 1.1.4
  • Development Dependencies (5):

  • bundler ~> 1.3
  • rake ~> 10.1
  • rspec ~> 2.14
  • simplecov ~> 0.7
  • yard ~> 0.8
  • Owners:

    Authors:

    • Bozhidar Batsov

    SHA 256 checksum:

    6935abc7d1cc704bf2c96646b1441270c3415ab8be1a7776686ff36ad3cd38bc

    Total downloads 263,659,349

    For this version 23,095

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.2

    New versions require MFA: true

    Links: