RubyGems Navigation menu

paranoia 2.4.2

Paranoia is a re-implementation of acts_as_paranoid for Rails 3, 4, and 5, using much, much, much less code. You would use either plugin / gem if you wished that when you called destroy on an Active Record object that it didn't actually destroy it, but just "hid" the record. Paranoia does this by setting a deleted_at field to the current time when you destroy a record, and hides it by scoping all queries on your model to only include records which do not have a deleted_at field.

Versionen:

  1. 2.4.2 - April 26, 2019 (22,5 KB)
  2. 2.4.1 - April 10, 2018 (22,5 KB)
  3. 2.4.0 - November 03, 2017 (22 KB)
  4. 2.3.1 - April 27, 2017 (21,5 KB)
  5. 2.3.0 - April 14, 2017 (21,5 KB)
Zeige alle Versionen (33 total)

Runtime Abhängigkeiten (1):

  • activerecord >= 4.0, < 6.1
  • Development Abhängigkeiten (2):

  • bundler >= 1.0.0
  • rake >= 0
  • Besitzer:

    Autoren:

    • radarlistener@gmail.com

    SHA 256-Prüfsumme:

    97cda1624732623aae9a331ea624e2dc4eeb67b58611cb39d8545dddc09fab3b

    Downloads insgesamt 21.351.886

    Für diese Version 3.994.845

    Gemfile:
    = In die Zwischenablage kopieren Kopiert!

    installieren:
    =

    Lizenz:

    MIT

    Erforderliche Ruby-Version: >= 2.0

    Required Rubygems Version: >= 1.3.6

    Links: