RubyGems Navigation menu

http 5.0.0

An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.

Versions:

  1. 5.1.1 - December 17, 2022 (81 KB)
  2. 5.1.0 - June 17, 2022 (80 KB)
  3. 5.0.4 - October 07, 2021 (78.5 KB)
  4. 5.0.3 - October 06, 2021 (78.5 KB)
  5. 5.0.2 - September 10, 2021 (79.5 KB)
  6. 5.0.0 - May 13, 2021 (77.5 KB)
Show all versions (102 total)

Runtime Dependencies (4):

addressable ~> 2.3
http-cookie ~> 1.0
llhttp-ffi ~> 0.0.1

Development Dependencies (1):

bundler ~> 2.0

Owners:

Pushed by:

Authors:

  • Tony Arcieri, Erik Michaels-Ober, Alexey V. Zapparov, Zachary Anker

SHA 256 checksum:

e378d95dcc8d713967f525326986c3162f2ceebe228f168231a8cf31a12dfbfd

Total downloads 92,646,861

For this version 296,227

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 2.5

New versions require MFA: true

Links: