RubyGems Navigation menu

http 5.0.0.pre

An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.

Versions:

  1. 5.1.1 - December 17, 2022 (81 KB)
  2. 5.1.0 - June 17, 2022 (80 KB)
  3. 5.0.4 - October 07, 2021 (78.5 KB)
  4. 5.0.3 - October 06, 2021 (78.5 KB)
  5. 5.0.2 - September 10, 2021 (79.5 KB)
  6. 5.0.0.pre - February 04, 2019 (72 KB)
Show all versions (102 total)

Runtime Dependencies (4):

addressable ~> 2.3
http-cookie ~> 1.0
http-parser ~> 1.2.0

Development Dependencies (1):

bundler ~> 2.0

Owners:

Authors:

  • Tony Arcieri, Erik Michaels-Ober, Alexey V. Zapparov, Zachary Anker

SHA 256 checksum:

48e7ff493247960d378db34feefc8339874d42e70d689fcbb3e06eeee3b299fa

Total downloads 93,260,142

For this version 115,278

Gemfile:
= Copy to clipboard Copied!

install:
=

License:

MIT

Required Ruby Version: >= 2.3

New versions require MFA: true

Required Rubygems Version: > 1.3.1

Links: