RubyGems Navigation menu

http 0.7.4

An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 5.2.0 - February 05, 2024 (83.5 KB)
  2. 5.1.1 - December 17, 2022 (81 KB)
  3. 5.1.0 - June 17, 2022 (80 KB)
  4. 5.0.4 - October 07, 2021 (78.5 KB)
  5. 5.0.3 - October 06, 2021 (78.5 KB)
  6. 0.7.4 - March 31, 2015 (53.5 KB)
Show all versions (103 total)

Runtime Dependencies (2):

http-form_data ~> 1.0.0
http_parser.rb ~> 0.6.0

Development Dependencies (1):

bundler ~> 1.0

Owners:

Authors:

  • Tony Arcieri, Erik Michaels-Ober, Aleksey V. Zapparov

SHA 256 checksum:

4a025570e71bd69558fae9e00c77f32e62daa614413138dd50f263a891f6a67e

Total downloads 124,343,787

For this version 120,874

License:

MIT

Required Ruby Version: >= 0

New versions require MFA: true

Links: