RubyGems Navigation menu

chef 17.0.242-universal-mingw32

A systems integration framework, built to bring the benefits of configuration management to your entire infrastructure.

Versions:

  1. 17.3.48 - July 21, 2021 universal-mingw32 (76.1 MB)
  2. 17.3.48 - July 21, 2021 (1.58 MB)
  3. 17.2.29 - June 09, 2021 universal-mingw32 (76 MB)
  4. 17.2.29 - June 09, 2021 (1.55 MB)
  5. 17.1.35 - May 11, 2021 universal-mingw32 (76 MB)
  6. 17.0.242 - April 28, 2021 universal-mingw32 (76 MB)
Show all versions (562 total)

Runtime Dependencies (46):

  • addressable >= 0
  • bcrypt_pbkdf ~> 1.1
  • chef-config = 17.0.242
  • chef-utils = 17.0.242
  • chef-vault >= 0
  • chef-zero >= 14.0.11
  • diff-lcs >= 1.2.4, < 1.4.0
  • ed25519 ~> 1.2
  • erubis ~> 2.7
  • ffi >= 1.5.0
  • ffi-libarchive ~> 1.0, >= 1.0.3
  • ffi-yajl ~> 2.2
  • highline >= 1.6.9, < 3
  • iniparse ~> 1.4
  • inspec-core ~> 4.23
  • iso8601 >= 0.12.1, < 0.14
  • license-acceptance >= 1.0.5, < 3
  • mixlib-archive >= 0.4, < 2.0
  • mixlib-authentication >= 2.1, < 4
  • mixlib-cli >= 2.1.1, < 3.0
  • mixlib-log >= 2.0.3, < 4.0
  • mixlib-shellout >= 3.1.1, < 4.0
  • net-sftp >= 2.1.2, < 4.0
  • net-ssh >= 5.1, < 7
  • net-ssh-multi ~> 1.2, >= 1.2.1
  • ohai ~> 17.0
  • pastel >= 0
  • plist ~> 3.2
  • proxifier ~> 1.0
  • syslog-logger ~> 1.6
  • train-core ~> 3.2, >= 3.2.28
  • train-winrm >= 0.2.5
  • tty-prompt ~> 0.21
  • tty-screen ~> 0.6
  • tty-table ~> 0.11
  • uuidtools >= 2.1.5, < 3.0
  • win32-api ~> 1.5.3
  • win32-certstore ~> 0.6.2
  • win32-event ~> 0.6.1
  • win32-eventlog = 0.6.3
  • win32-mmap ~> 0.4.1
  • win32-mutex ~> 0.4.2
  • win32-process ~> 0.9
  • win32-service >= 2.1.5, < 3.0
  • win32-taskscheduler ~> 2.0
  • wmi-lite ~> 1.0
  • Owners:

    Pushed by:

    Authors:

    • Adam Jacob

    SHA 256 checksum:

    ed428952ec4ebf2dfee95b648c82eb9b3037a07fa310248fe709b5f1235e3f24

    Total downloads 16,665,796

    For this version 347

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    Apache-2.0

    Required Ruby Version: >= 2.6.0

    Links: