RubyGems Navigation menu

spy 1.0.5

Spy is a mocking library that was made for the modern age. It supports only 2.1.0+. Spy by default will raise an error if you attempt to stub a method that doesn't exist or call the stubbed method with the wrong arity.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.0.5 - December 25, 2022 (22 KB)
  2. 1.0.4 - December 21, 2022 (22 KB)
  3. 1.0.3 - September 15, 2022 (33.5 KB)
  4. 1.0.2 - January 10, 2022 (33.5 KB)
  5. 1.0.1 - August 20, 2020 (32.5 KB)
Show all versions (22 total)

Development Dependencies (7):

Owners:

Pushed by:

Authors:

  • Ryan Ong

SHA 256 checksum:

babd137834e09fb5e58b8d8bc777649052bc376d9618a4cb34a29e8091aa553c

Total downloads 2,480,033

For this version 335,152

License:

MIT

Required Ruby Version: >= 2.7.0

Links: