RubyGems Navigation menu

solid_assert 1.1.0

Assert utility for ruby. It lets you code your assumptions and code invariants, so they are checked automatically. It can be deactivated, so you it doesn't affect to your program performance (for example, in production).

Versions:

  1. 1.1.0 - September 22, 2021 (8 KB)
  2. 1.0.0 - May 26, 2016 (7.5 KB)
  3. 0.8.0 - February 08, 2016 (8 KB)
  4. 0.7.3 - September 20, 2011 (8 KB)
  5. 0.7.2 - September 19, 2011 (8 KB)
Show all versions (9 total)

Development Dependencies (3):

  • bundler ~> 2.0
  • rake ~> 13.0
  • rspec ~> 3.4
  • Owners:

    Pushed by:

    Authors:

    • Jorge Manrubia

    SHA 256 checksum:

    3f15d35bb2c7f0fad420b6b141bf8a399e8a603e07939d1929f440487cad72de

    Total downloads 374,624

    For this version 2,783

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 2.3

    Links: