RubyGems Navigation menu

sinatra-synchrony 0.1.1

Bootstraps in code required to take advantage of EventMachine/EM-Synchrony's concurrency enhancements for slow IO. Patches TCPSocket, which makes anything based on it EM-aware (including RestClient). Includes patch for tests. Requires ruby 1.9.

Versiones:

  1. 0.4.1 - September 11, 2012 (8,5 KB)
  2. 0.4.0 - August 09, 2012 (8,5 KB)
  3. 0.3.2 - June 26, 2012 (8,5 KB)
  4. 0.3.0 - October 21, 2011 (8,5 KB)
  5. 0.2.1 - September 14, 2011 (8,5 KB)
  6. 0.1.1 - August 03, 2011 (8,5 KB)
Mostrar todas las versiones (20 total)

dependencias de Runtime (6):

dependencias de Development (4):

  • minitest >= 0
  • rack-test = 0.5.7
  • rake >= 0
  • wrong = 0.5.0
  • Propietarios:

    Autores:

    • Kyle Drake

    SHA 256 checksum:

    a2efc272b1c2d2e36ac2f35c3119f7ec69b5ad514545fa5a86742877e4ddb930

    Total de descargas 64.668

    Para esta versión 3.900

    Gemfile:
    = Copiar al portapapeles ¡Copiado!

    instalar:
    =

    Licencias:

    N/A

    Versión de Ruby requerida: Ninguno

    Versión de Rubygems requerida: >= 1.3.4

    Enlace: