RubyGems Navigation menu

sequel_tools 0.1.9

Offer tooling for common database operations, such as running Sequel migrations, store and load from the database schema, rollback, redo some migration, rerun all migrations, display applied and missing migrations. It allows integration with Rake, while being lazily evaluated to not slow down other Rake tasks. It's also configurable in order to support more actions and database vendors. Some tasks are currently implemented for PostgreSQL only for the time being out of the box. It should be possible to complement this gem with another one to support other database vendors, while taking advantage of the build blocks provided by this tool set.

版本列表:

  1. 0.1.9 - May 20, 2021 (15.5 KB)
  2. 0.1.8 - May 19, 2021 (15.5 KB)
  3. 0.1.7 - May 04, 2018 (15.5 KB)
  4. 0.1.6 - January 08, 2018 (15.5 KB)
  5. 0.1.5 - December 18, 2017 (15.5 KB)
显示所有 (10 个版本)

Runtime 依赖关系 (1):

Development 依赖关系 (4):

所有者:

Pushed by:

作者:

  • Rodrigo Rosenfeld Rosas

SHA 256 checksum:

236f36b9f780582d87d8fa7ad126d52aa568d479ccb5896594602e79d3abe2b9

下载总次数 18,549

这个版本 4,011

Gemfile:
= 复制到剪贴板 已复制

安装:
=

许可:

MIT

需要的 Ruby 版本: >= 0

相关链接: