RubyGems Navigation menu

sequel_pg 1.14.0

sequel_pg overwrites the inner loop of the Sequel postgres adapter row fetching code with a C version. The C version is significantly faster than the pure ruby version that Sequel uses by default. sequel_pg also offers optimized versions of some dataset methods, as well as adds support for using PostgreSQL streaming.

Versions:

  1. 1.14.0 - September 22, 2020 (25 KB)
  2. 1.13.0 - April 13, 2020 (24.5 KB)
  3. 1.12.5 - March 23, 2020 (24.5 KB)
  4. 1.12.4 - January 02, 2020 (24.5 KB)
  5. 1.12.3 - January 02, 2020 (24.5 KB)
Show all versions (84 total)

Runtime Dependencies (2):

  • pg >= 0.18.0, != 1.2.0
  • sequel >= 4.38.0
  • Owners:

    Pushed by:

    Authors:

    • Jeremy Evans

    SHA 256 checksum:

    66da328c5dc00918a43be5cf9df1267d718f79e49f2ea6302ff4ba6512b36b56

    Total downloads 2,693,015

    For this version 251,618

    Gemfile:
    = Copy to clipboard Copied!

    install:
    =

    License:

    MIT

    Required Ruby Version: >= 1.9.3

    Links: